cancel
Showing results for 
Search instead for 
Did you mean: 

DE 4.1 - DLT UI Walkthrough Error in Classroom Setup

blockee
New Contributor II

Trying to follow along with the DLT videos in the academy. I get an error when running the setup script. Error trace below. It stems from running Classroom-Setup-04.1

DA = DBAcademyHelper(course_config=course_config,

                     lesson_config=lesson_config)

I'm using the 11.3 LTS runtime which matches the version requirement in the Version Info notebook.

An error occurred while calling o534.tags. Trace:

py4j.security.Py4JSecurityException: Method public scala.collection.immutable.Map com.databricks.backend.common.rpc.CommandContext.tags() is not whitelisted on class class com.databricks.backend.common.rpc.CommandContext

at py4j.security.WhitelistingPy4JSecurityManager.checkCall(WhitelistingPy4JSecurityManager.java:473)

at py4j.Gateway.invoke(Gateway.java:305)

at py4j.commands.AbstractCommand.invokeMethod(AbstractCommand.java:132)

at py4j.commands.CallCommand.execute(CallCommand.java:79)

at py4j.ClientServerConnection.waitForCommands(ClientServerConnection.java:195)

at py4j.ClientServerConnection.run(ClientServerConnection.java:115)

at java.lang.Thread.run(Thread.java:750)

3 REPLIES 3

Anonymous
Not applicable

@Brent Lockee​ :

The error you are seeing is related to a security feature in Py4J that prevents access to certain methods or classes that could be potentially dangerous. In this case, the method

com.databricks.backend.common.rpc.CommandContext.tags() is not whitelisted, which means it's not allowed to be accessed.

To resolve this issue, you can try upgrading the Databricks Runtime version to a newer one. Alternatively, you can also try downgrading the Py4J version to an older one.

If you are using the Databricks community edition, you may not have permission to modify the runtime or install additional packages. In that case, you can try using a different runtime version and see if the issue persists.

Anonymous
Not applicable

Hi @Brent Lockee​ 

Hope all is well! Just wanted to check in if you were able to resolve your issue and would you be happy to share the solution or mark an answer as best? Else please let us know if you need more help. 

We'd love to hear from you.

Thanks!

blockee
New Contributor II

I tried with Py4J versions 0.10.9.5, .3, and .1. None of those versions worked. I also tried upgrading the runtime to 13.0 and 12.1 and saw the same issue. The 13.0 runtime upgraded Py4J to 0.10.9.7 and that didn't resolve the issue. The error stayed the same in all cases.

Our Databricks is deployed in a private VNET for Hippa compliance. I'm wondering if that is related.

Welcome to Databricks Community: Lets learn, network and celebrate together

Join our fast-growing data practitioner and expert community of 80K+ members, ready to discover, help and collaborate together while making meaningful connections. 

Click here to register and join today! 

Engage in exciting technical discussions, join a group with your peers and meet our Featured Members.