cancel
Showing results for 
Search instead for 
Did you mean: 

FileNotFoundError: [Errno 2] No such file or directory: when I try to unzip .tar or .zip files it gives me this error

Tonny_Stark
New Contributor II

Hello, how are you? I have a small problem. I need to unzip some .zip, tar files. and gz inside these may have multiple files trying to unzip the .zip files i got this error

FileNotFoundError: [Errno 2] No such file or directory:

but the files are in the path, please help me

error

6 REPLIES 6

Debayan
Esteemed Contributor III
Esteemed Contributor III

Hi, Could you also please ls the file name and see if it is present.

Also, please check if the file path is correct.

Refer: https://docs.databricks.com/files/index.html

Also, please tag @Debayan​ with your next response which will notify me. Thank you!

Tonny_Stark
New Contributor II

Hi @Debayan Mukherjee​ 

yes you already try using /dbfs/mnt

dbfs:/mnt

mnt/

I share the image where I show how I am doing it and where the file is located

I have tried placing

/dbfs/mnt/

dbfs:/mnt/

/mnt/

following what the online documentation indicates.

but nothing, as you can see in the image in the red rectangle you can view the file but when I want to decompress either a .zip, a .tar or a .gz it simply sends me the error,

I hope you can help me

image

Anonymous
Not applicable

@Alfredo Vallejos​ Try changing the path from "/dbfs:/mnt" to "/dbfs/mnt" in the code.

Please refer to below document on how to work with files in dbfs location.

https://docs.databricks.com/files/index.html

Hi @John Lourdu​ yes i already tried but it doesn't work

Welcome to Databricks Community: Lets learn, network and celebrate together

Join our fast-growing data practitioner and expert community of 80K+ members, ready to discover, help and collaborate together while making meaningful connections. 

Click here to register and join today! 

Engage in exciting technical discussions, join a group with your peers and meet our Featured Members.