- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
12-10-2019 08:36 AM
Job output, such as log output emitted to stdout, is subject to a 20MB size limit. If the total output has a larger size, the run will be canceled and marked as failed.
That was my problem, to "fix it" I've just set the logging level to ERRORval sc = SparkContext.getOrCreate(conf) sc.setLogLevel("ERROR")It was solved- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
12-10-2019 11:56 AM
According to https://docs.databricks.com/jobs.html#jar-job-tips:
"Job output, such as log output emitted to stdout, is subject to a 20MB size limit. If the total output has a larger size, the run will be canceled and marked as failed."That was my problem, to "fix it" I've just set the logging level to ERRORval sc = SparkContext.getOrCreate(conf)sc.setLogLevel("ERROR")This workaround works for me- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
01-20-2020 02:20 AM
I am facing the same error but the log output to stdout is not an issue as the log file size turns out to be < 2 MB. So that issue is ruled out. Moreover, our job is dummy for testing purposes and is not doing any memory intensive operation. Its purely running a simple thread that keeps on logging to the stdout every 5 mins.
Still the cluster is getting timed out.
Below is the post i have submitted on stack overflow.