Isi
Honored Contributor III

Hello @jeremylllin ,

From the error message:
Access to storage destination is denied because of serverless network policy

Databricks serverless environments require explicit network access policies to reach AWS resources like S3. Even if you’ve already configured credentials and external locations, these policies act as an extra layer of protection.

Check your account Network policies(Serverless) in the admin console under Cloud resources > Network > Network policies (Serverless):

Captura de pantalla 2025-06-22 a las 13.00.31.png

 Check if you have "Allow access to all destinations"

If that doesn't solve your problems check this Serverless Network Access Control for AWS 

This page explains how to configure private connectivity from Serverless compute to your in-region AWS S3 buckets using the Databricks account console UI.

Isi_1-1750590817323.png

A dedicated and private connection: Ensures secure and isolated access between your serverless workspaces and AWS S3, limiting access to authorized connections only.

 

Hope this helps, 🙂

Isi