Hello everyone,
I noticed that when I tried to convert some external table to managed one using the alter table catalog.schema.table_name set managed command (like suggested by databricks) sometimes I will encounter this error:
Error running query: com.databricks.sql.managedcatalog.UnityCatalogServiceException: [RequestId=xxxx ErrorClass=FEATURE_DISABLED] Global UC is disabled for PrivilegedGenerateTemporaryTableCredential.
But what's strage is that if then I retry the very same command, on the same table, without restarting the cluster on anything it will succeed. FYI I need to use a serverless cluster for running this command for a series of company reason. I have looked into the documentation and could not find anything. Can someone help me out? thank a lot in advance.