Showing results for 
Search instead for 
Did you mean: 
Data Engineering
Join discussions on data engineering best practices, architectures, and optimization strategies within the Databricks Community. Exchange insights and solutions with fellow data engineers.
Showing results for 
Search instead for 
Did you mean: 

VScode extension - certificate signature failure

New Contributor II

Hi everyone,

I'm trying to use the new Databricks extension (v0.3.10) for VS code (v1.77.3).

I face this problem when connecting to our workspace:

image.pngThis problem persists when I tried to login through az CLI with our SSO, or through local config using PAT.

Here's the config I have tried with the .databrickscfg file. I could still use this work around for Databricks CLI to access our workspace (not really a thing I should do in security perspective, however):

host = https://*
token = *
jobs-api-version = 2.0
insecure = True

I googled around how to add our custom CA certificate but couldn't find any.

I really appreciate it if someone can guide me through how to set up the custom CA certificate for the extension.

Thank you for your time!


Not applicable

@Minh Duc Nguyen​ :

It seems like the error you are facing is due to a failure in verifying the SSL certificate of your Databricks workspace. To resolve this, you need to add the custom CA certificate to your VS Code settings. Here's how you can do it:

  1. Obtain the custom CA certificate from your Databricks administrator.
  2. Open VS Code and press "Ctrl + Shift + P" (Windows) or "Cmd + Shift + P" (Mac) to open the command palette.
  3. Type "settings" and select "Preferences: Open User Settings" from the list of options.
  4. In the search bar, type "certificates" to filter the settings.
  5. Under "HTTP", find the setting for "Certificates: Authority". Click on "Edit in settings.json" to open the settings file.
  6. In the settings file, add the path to your custom CA certificate in the following format:
"http.proxyStrictSSL": true,
"http.proxyAuthorization": null,
"http.proxy": "",
"http.proxySupport": "off",
"http.proxyCertificate": "path/to/custom/ca/certificate.pem",
"http.proxyCertificates": [
"http.certificates": [
"http.proxyCaCertificates": [

Save the settings file and try connecting to your Databricks workspace again through the VS Code extension.

If the issue persists, you may want to try updating your VS Code and Databricks extension to the latest versions, or contact Databricks support for further assistance.

Join 100K+ Data Experts: Register Now & Grow with Us!

Excited to expand your horizons with us? Click here to Register and begin your journey to success!

Already a member? Login and join your local regional user group! If there isn’t one near you, fill out this form and we’ll create one for you to join!