cancel
Showing results for 
Search instead for 
Did you mean: 
Data Governance
Join discussions on data governance practices, compliance, and security within the Databricks Community. Exchange strategies and insights to ensure data integrity and regulatory compliance.
cancel
Showing results for 
Search instead for 
Did you mean: 

Table ACLs, secrets, and compute clusters

Mr__E
Contributor II

I am adding a credential to access MongoDB through the Python MongoDB Spark connector. It is stored as a secret and the `users` group has `MANAGE` ACL privileges. I turned on table ACLs and created a `High Concurrency` compute cluster. I then run a script that attempts to read from MongoDB, but fails due to authentication issues. If I put in the password manually, it succeeds. If I use the same script on a non-High Concurrency (aka no table ACL) cluster, it succeeds. Only when I use table ACLs does it fail. Anyone know if I'm missing a setting?

1 ACCEPTED SOLUTION

Accepted Solutions

Mr__E
Contributor II

| Check if privileges are set properly.

I added `MANAGE` permissions for `users` to the secret scope and also gave `users` restart access to the compute cluster. Are there other permissions I should be setting?

| Also, maybe check that passwords are exactly same - the one in your script and the one you're pasting manually.

Thanks for getting back. I checked that they are the same by copy-pasting and pasting the same one during `secrets put` and in the notebook (I made sure to remove the extra line from the file). It is working correctly when I don't use the high-concurrency cluster as noted before, so that suggests the secrets is correct.

View solution in original post

3 REPLIES 3

AmanSehgal
Honored Contributor III

Interesting. Check if privileges are set properly.

Also, maybe check that passwords are exactly same - the one in your script and the one you're pasting manually.

Mr__E
Contributor II

| Check if privileges are set properly.

I added `MANAGE` permissions for `users` to the secret scope and also gave `users` restart access to the compute cluster. Are there other permissions I should be setting?

| Also, maybe check that passwords are exactly same - the one in your script and the one you're pasting manually.

Thanks for getting back. I checked that they are the same by copy-pasting and pasting the same one during `secrets put` and in the notebook (I made sure to remove the extra line from the file). It is working correctly when I don't use the high-concurrency cluster as noted before, so that suggests the secrets is correct.

Atanu
Esteemed Contributor
Esteemed Contributor

@Erik Louie​  looks the issue is resolved. Please let me know if you need further help on this. Thanks!

Join 100K+ Data Experts: Register Now & Grow with Us!

Excited to expand your horizons with us? Click here to Register and begin your journey to success!

Already a member? Login and join your local regional user group! If there isn’t one near you, fill out this form and we’ll create one for you to join!