Showing results for 
Search instead for 
Did you mean: 
Data Engineering
Join discussions on data engineering best practices, architectures, and optimization strategies within the Databricks Community. Exchange insights and solutions with fellow data engineers.
Showing results for 
Search instead for 
Did you mean: 

PermissionError / Operation not Permitted with Files-in-Repos

New Contributor II

I've been running a notebook using files-in-repo. Previously this has worked fine. I'm unsure what's changed (I was testing integration with DCS on older runtimes, but don't think I made any persistent changes)--but now it's throwing an error (always a variant of "Operation not permitted" or "PermissionError'). I'm unable to access a requirements.txt file or load modules in my repo.

As an example, I'll use the databrick files-in-repo notebook. Loading a module:

imageLoading a requirements.txt:

imageSome other information:

  • Running on a single-node cluster with DBR 12.0 and no DCS
  • Files-in-Repo is enabled for DBR 8.4+
  • The Python PWD is my repository path, and the and os path include my repository path.

I'm new to DB; is there something obvious I'm overlooking here?


Esteemed Contributor III

In my opinion, requirements.txt is just in another folder. So please save the requirements file in dbfs and put the full path. And also magic command pip has to be prefixed with a % sign.

%pip install -r /dbfs/requirements.txt

Appreciate the advice, but using an absolute path and using % doesn't fix the problem.

It's almost like DB thinks files-in-repos is not enabled for this cluster.

New Contributor II

Hi @jfarmer , did you solved this issue? I'm having exactly the same challenge.

Join 100K+ Data Experts: Register Now & Grow with Us!

Excited to expand your horizons with us? Click here to Register and begin your journey to success!

Already a member? Login and join your local regional user group! If there isn’t one near you, fill out this form and we’ll create one for you to join!