cancel
Showing results for 
Search instead for 
Did you mean: 
Data Engineering
Join discussions on data engineering best practices, architectures, and optimization strategies within the Databricks Community. Exchange insights and solutions with fellow data engineers.
cancel
Showing results for 
Search instead for 
Did you mean: 

validate bundle does not work on windows 10 PRO x64

vanagnostopoulo
New Contributor II

I use the databricks cli

databricks_cli_0.221.1_windows_amd64-signed

and when I run

databricks bundle validate

in my project I get

"Error: no shell found"

 

In git-bash it works but I have other problems there.

5 REPLIES 5

jacovangelder
Contributor III

Is it just the validate command or also other databricks cli commands? For example databricks bundle init? does that work?

is databricks cli added to your %PATH% variable inside your system settings?
Can you try to update databricks cli? You're using an older version

The rest work

databricks bundle init works

databricks auth profiles works

I can login through a browser

databricks auth login --host <workspace-url> 

 

even in git-bash If I export a BROWSER variable like

export BROWSER="/c/Program Files/Mozilla Firefox/firefox.exe"

authentication works

 

In git-bash it does not complain for shell (but there I have proxy problems)

I use latest databricks cli (not legace, see above)

jacovangelder
Contributor III

That's strange. Just checking, are you running it from the right folder? (location of databricks.yml file)? 

In both cases, command prompt and git-bash I run it from the correct folder.

Still, I do not understand the "shell" thing, where it is coming from.

Join 100K+ Data Experts: Register Now & Grow with Us!

Excited to expand your horizons with us? Click here to Register and begin your journey to success!

Already a member? Login and join your local regional user group! If there isn’t one near you, fill out this form and we’ll create one for you to join!