cancel
Showing results for 
Search instead for 
Did you mean: 
Machine Learning
Dive into the world of machine learning on the Databricks platform. Explore discussions on algorithms, model training, deployment, and more. Connect with ML enthusiasts and experts.
cancel
Showing results for 
Search instead for 
Did you mean: 

Is it wise to use a more recent MLFlow Python package version or is the DB Runtime compatibility matrix strict about MLFlow versions?

fermin_vicente
New Contributor III

More concretely, should we fix the dependency version at MAJOR, MINOR or PATCH?

For example, MLFlow 1.30.0 is available and latest DBR 11.3 LTS is compatible with 1.29.0

My question comes from the fact that installing our own libraries that use MLFlow, dependency resolution might try to get the latest version if we don't properly pin it.

Thanks!

2 REPLIES 2

Debayan
Esteemed Contributor III
Esteemed Contributor III

fermin_vicente
New Contributor III

Hi! thanks for the reply, although maybe you didn't notice that I linked to the same url, so we're aware of the matrix.

The question is, is it compatible solely with 1.29.0? We want to know which dependency should we use in all our projects that might be running against/in the platform:

  • mlflow==1.29.0
  • mlflow==1.29.*
  • mlflow==1.*

Hope this is clearer! thanks

Join 100K+ Data Experts: Register Now & Grow with Us!

Excited to expand your horizons with us? Click here to Register and begin your journey to success!

Already a member? Login and join your local regional user group! If there isn’t one near you, fill out this form and we’ll create one for you to join!