Showing results for 
Search instead for 
Did you mean: 
Administration & Architecture
Explore discussions on Databricks administration, deployment strategies, and architectural best practices. Connect with administrators and architects to optimize your Databricks environment for performance, scalability, and security.
Showing results for 
Search instead for 
Did you mean: 

unable to publish power bi dashboard with Databricks as source

New Contributor

Able to connect using personal access token and view the data in Hive; but when I publish to dashboard to share-point it results in :- PERMISSION_DENIED: You do not have permissions to autostart 1127-******-*********


Community Manager
Community Manager

Hi @test-fall,

The PERMISSION_DENIED error typically occurs when your user account lacks the necessary permissions to perform a specific action. In your case, it seems related to publishing a dashboard to SharePoint.

Let’s troubleshoot this issue:

  1. Check Permissions:

    • First, verify that your user account has the appropriate permissions to publish dashboards to SharePoint. Ensure you have the necessary rights to create and manage content in SharePoint.
    • Confirm that you are using the correct credentials and that your access token is valid.
  2. SharePoint Configuration:

    • Make sure the SharePoint site or library where you intend to publish the dashboard allows for external content.
    • Check if there are any specific SharePoint settings or restrictions that might prevent publishing.
  3. Autostart Permissions:

    • The error message mentions autostart permissions. This could be related to starting services or processes automatically.
    • Ensure that you have the necessary permissions to initiate processes or services (such as autostarting a job or task).
  4. File Permissions:

    • If you’re dealing with specific files or directories, verify their permissions. Use the ls -l command to view permissions and ownership.
    • For example:
      $ ls -l
      -rw-rw-r-- 1 linuxconfig linuxconfig 32 Jan 28 17:15
      In the output above, the owner and group have read and write permissions, but not execute permissions. To add execute permissions, use:
      $ chmod +x
  5. Root or Sudo Access:

    • If necessary, elevate your permissions by using the root account or sudo.
    • For example, to change permissions on a directory:
      $ sudo chmod +w /path/to/dir

Remember that the root user account always has full permissions on any file, regardless of what has ...1. Make sure to adjust permissions accordingly and try publishing the dashboard again. If the issue persists, consider reaching out to your system administrator or SharePoint support for further assistance. 🚀

Join 100K+ Data Experts: Register Now & Grow with Us!

Excited to expand your horizons with us? Click here to Register and begin your journey to success!

Already a member? Login and join your local regional user group! If there isn’t one near you, fill out this form and we’ll create one for you to join!